Moodle 2.1 or later requires at least PHP 5.3.2 (currently using version 5.2.17).
Please upgrade your server software or install older Moodle version.